Monthly Archives: November 2014

Solved: linphone: error: libupnp >= 1.6 < 1.5 required.

If when attempting to compile linphone you get this error when running ./configure – error: libupnp >= 1.6 < 1.5 required. Then you can try what L Miller suggests and do: apt-get remove libupnp4-dev And then: apt-get install libupnp6-dev This seems to do the trick when compiling on Ubuntu 14.04. After upgrading this library I started over in the compiling instructions with autogen: – Compile linphone $ ./autogen.sh $ ./configure $ make && sudo make install $ sudo ldconfig If that still doesn’t work then see http://akh1.blogspot.hk/2014/04/compiling-linphone-37-in-ubuntu.html

Posted in Linux, Software | Tagged , | Leave a comment

How to disable the LEDs on the PogoPlug running Debian Squeeze

If you’ve installed Debian Squeeze on the PogoPlug you’ll notice there is no longer an /sys/module/xce/sections/ or /dev/xce path for you to echo commands to. However, you can still control the LEDs by using the sys -> devices -> platform -> LEDS / GPIO How to disable the LEDs echo 0 > /sys/devices/platform/leds-gpio/leds/status:red:fault/brightness echo 0 > /sys/devices/platform/leds-gpio/leds/status:green:health/brightness How to make the LED green echo 0 > /sys/devices/platform/leds-gpio/leds/status:red:fault/brightness echo 1 > /sys/devices/platform/leds-gpio/leds/status:green:health/brightness How to make the LED red echo 1 > /sys/devices/platform/leds-gpio/leds/status:red:fault/brightness echo 0 > /sys/devices/platform/leds-gpio/leds/status:green:health/brightness How to make the LED orange / yellow echo 1 > /sys/devices/platform/leds-gpio/leds/status:red:fault/brightness echo 1 > /sys/devices/platform/leds-gpio/leds/status:green:health/brightness You can also try using values 1-255 to control the brightness but I didn’t see much difference between different numbers. ymmv. Also, if you wish to read the status of the LEDs you can do so by using something like cat with these paths: cat /sys/devices/platform/leds-gpio/leds/status:red:fault/brightness A value of 0 indicates the LED is off. Most likely if you are running Debian there will be no events that turn the LEDs on – but in case you have issues you can disable system events from triggering the LEDS you also need to change the ‘triggers’ – first check out the existing ones: cat /sys/devices/platform/leds-gpio/leds/status:green:health/trigger This results in: [none] nand-disk timer oneshot ide-disk1 ide-disk2 heartbeat gpio default-on mmc0 And for the red led use: cat /sys/devices/platform/leds-gpio/leds/status:red:fault/trigger Which should result in: [none] nand-disk timer oneshot ide-disk1 ide-disk2 heartbeat gpio default-on mmc0 Next, to disable the events from triggering the LEDs run: … Continue reading

Posted in Server Admin, Tech Tips | Tagged , | Leave a comment

How to setup cPanel on Amazon EC2 with Centos 6.4

I had a lot of problems setting up a cPanel server on Amazon EC2. On my first attempt I used a CentOS image from the AWS marketplace but using one of these images has a very bad side effect of not being able to resize, clone, and/or mount the root file system to another instance ( think about the issues with data recovery or fixing an un-bootable ec2 instance – yuck ) – this is what dgFactor is referring to in his comment My next attempt I had launched the instance but after it was launched cPanel would not install, giving errors similar to: [20130131.123334] Setting up Install Process [20130131.123334] No package wget available. [20130131.123335] Nothing to do [20130131.123339] E Sysup: Needed system RPMs were not installed: wget [20130131.123339] ***** FATAL: Cannot proceed. Needed system RPMs were not installed. [20130131.123339] The Administrator will be notified to review this output when this script completes [20130131.123339] E Detected events which require user notification during updatenow. Will send iContact the log => Log closed Thu Jan 31 12:33:39 2013 [20130131.123339] E Running `/usr/local/cpanel/scripts/updatenow –upcp –log=/var/cpanel/updatelogs/update.1359657200.log` failed, exited with code 4608 => Log closed Thu Jan 31 12:33:39 2013 What seems to have happened here is that the file system was full. Even though I had increased the default drive size from 5GB to 40GB when the system booted the additional space was unavailable: This can be confirmed from SSH after connecting to the instance: [[email protected] ~]# df -h Filesystem Size Used Avail Use% … Continue reading

Posted in Linux, Server Administration | Tagged , | Leave a comment