Solved: linphone: error: libupnp >= 1.6 < 1.5 required.

If when attempting to compile linphone you get this error when running ./configure –

 error: libupnp >= 1.6 < 1.5 required.

Then you can try what L Miller suggests and do:

apt-get remove libupnp4-dev

And then:

apt-get install libupnp6-dev

This seems to do the trick when compiling on Ubuntu 14.04.

After upgrading this library I started over in the compiling instructions with autogen:

- Compile linphone

 $ ./autogen.sh
 $ ./configure 
 $ make && sudo make install 
 $ sudo ldconfig

If that still doesn’t work then see http://akh1.blogspot.hk/2014/04/compiling-linphone-37-in-ubuntu.html

Related Posts:

  • No Related Posts
This entry was posted in Linux, Software and tagged , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *